Talk:User group meeting & agenda 5 November 2008

From FamilySearch Wiki
Jump to: navigation, search

Brackets problem

Firefox interpretes 5B and 5D as [ and ] . This create a problem when doing external links. In the Family History Library Catalog - there are some urls containing [ and ] .

Glaring example is Klamath Falls, Oregon newsletter link I can't link Medford, Oregon LDS branch record for that reason alone because the url has both [ and ] in it.

dsammy 00:21, 2 November 2008 (UTC)

Test using Safari on a Mac: I cannot reproduce the problem, although I'm using Safari on a Mac. I noticed the URL listed in the link for the newsletter is different than what is found on FamilySearch. Here's the result of placing the URL (copied from FS) within single brackets, adding a space, then adding FHLC:


Test using Firefox on a Mac: The problem cannot be reproduced in Firefox on a Mac either. When the URL from FamilySearch is copied exactly as it appears, then a space is added before the FHLC, the result works just fine: FHLC --Fran 16:40, 5 November 2008 (UTC)

I see what dsammy is talking about. Here is the exact link (with the http colon slash slash removed):*,180,0

It appears that the %5B got somewhere interpretted as a '[' and messed up the link (although FamilySearch still found the article).

Here is the above link pasted in using IE6 and again below:*,180,0

Now the same test on Firefox on Linux: Here is the same link pasted and then again below:*,180,0

Hmmm, that worked too. Each time, the %5B did not get interpretted as a '['.

Thomas Lerman 17:04, 5 November 2008 (UTC)

Question: Does IE6 and Firefox on Linux have a different URL for the catalog page than what I see on Firefox and Safari on the Mac? Everything beyond the Society+ is added text in the URL than what I see. --Fran 20:08, 5 November 2008 (UTC)

Answer: I cannot think of a reason why the catalog would give you and me different URLs, but is technically possible. I did notice the link to the page in question on this page is slightly different than when you go to the actual page.

Addendum: I figured out why the URL is different for me than for others

From what I have seen (I have not been able to reproduce this), it seems like the problem happens BEFORE saving the article . . . either during the copy/paste process or within fckeditor. Thomas Lerman 20:56, 5 November 2008 (UTC)

Another test with a link that has both opening and closing brackets and*,180,0*,180,0 Okay, those work with IE6 (Win).

Same test with the same link:*,180,0*,180,0

Again, this appears to work on Firefox 1.5 (Linux). I have tried all of the above in three ways:

  1. Using the Link button in the WYSIWYG mode
  2. Pasting directly in WYSIWYG mode
  3. Pasting directly in Wikitext mode

Again, I believe it is happening some time before saving the article (copy/paste or editor).

Thomas Lerman 21:09, 5 November 2008 (UTC)

My Addendum: When I click on the link to the catalog entry, the URL does not include anything beyond the "Society+" portion of the URL. Even when I refresh the screen, the URL does not change. When I search or navigate to the catalog entry, I get the full URL. Note that the URL does not include brackets, even after I've pasted the URL into this chat, the URL remains the same as what I saw on the screen: (http was removed)*,180,0

--Fran 21:44, 5 November 2008 (UTC)

Which link did you click on? In the ones at the top, nothing exists in this discussion past that "Society+". It looks like it was lost before saving the discussion. I would guess they work on the links that I pasted in. Thomas Lerman 22:12, 5 November 2008 (UTC)

Page formatting problem in Firefox.

Another user, Gary Turner, found this page formatting error, it might be in the CSS encoding, he describes it on a portal talk page.

JamesAnderson 23:46, 2 November 2008 (UTC)

Past two meetings

Any notes from last week?

Have the rest of the items from two weeks ago been covered? My radiator is still not replaced, so will not be able to head to the meeting yet.

Saving from an edit

I just noticed that saving from an edit (IE6) shows me that I am being redirected to a page that is not secure. I do not remember seeing that before, Have something changed?